Download with plugins building for ever

I tried this download:

I tried it 6 hours ago and now again and still 30min “building” and I get no download.
I tried to build it with xcaddy now and still stuck.
Can somebody download or build me that caddy file?

$ xcaddy build v2.6.4 --with --with
2023/02/21 16:53:07 [INFO] Temporary folder: /tmp/buildenv_2023-02-21-1653.579170422
2023/02/21 16:53:07 [INFO] Writing main module: /tmp/buildenv_2023-02-21-1653.579170422/main.go
package main

import (
	caddycmd ""

	// plug in Caddy modules here
	_ ""
	_ ""
	_ ""

func main() {
2023/02/21 16:53:07 [INFO] Initializing Go module
2023/02/21 16:53:07 [INFO] exec (timeout=10s): /usr/local/go/bin/go mod init caddy 
go: creating new go.mod: module caddy
go: to add module requirements and sums:
	go mod tidy
2023/02/21 16:53:07 [INFO] Pinning versions
2023/02/21 16:53:07 [INFO] exec (timeout=0s): /usr/local/go/bin/go get -d -v 
go: added v1.0.1
go: added v2.6.4
go: added v0.17.2
go: added v2.1.2
go: added v0.0.0-20210107165309-348f09dbbbc0
go: added v1.6.0
go: added v1.5.2
go: added v0.0.0-20210407192527-94a9f03dee38
go: added v1.3.0
go: added v2.2.3
go: added v0.2.1
go: added v1.0.1
go: added v1.1.0
go: added v1.1.50
go: added v2.2.0
go: added v1.14.0
go: added v0.3.0
go: added v0.37.0
go: added v0.8.0
go: added v0.4.0
go: added v0.2.0
go: added v0.2.0
go: added v0.1.0
go: added v0.32.0
go: added v1.9.0
go: added v1.6.0
go: added v1.24.0
go: added v0.5.0
go: added v0.0.0-20221205204356-47842c84f3db
go: added v0.6.0
go: added v0.7.0
go: added v0.5.0
go: added v0.5.0
go: added v0.7.0
go: added v0.2.0
go: added v1.28.1
2023/02/21 16:53:08 [INFO] exec (timeout=0s): /usr/local/go/bin/go get -d -v 
go: added v0.0.0-20220527005842-9c71e343246b
go: added v1.41.0
go: added v1.0.0
go: added v0.0.0-20220518195853-a541bc8aa80f
2023/02/21 16:53:09 [INFO] exec (timeout=0s): /usr/local/go/bin/go get -d -v 
go: added v0.0.0-20221013172934-88290c6b74c4
2023/02/21 16:53:09 [INFO] exec (timeout=0s): /usr/local/go/bin/go get -d -v  

This is due to this bug in the go command:

(We think.)

Upgrading a plugin’s go.mod file to use the latest version of Caddy seems to fix it, but we’re not sure why. And neither is the Go team as of yet.

Sorry for the trouble. I’ve updated that plugin’s go.mod for now, which apparently works around the problem.

I tried it with the online download but it did not work

I try later to build it myself.

Ok on my local machine I am able to build it. :shushing_face:

Hi, can’t build on the caddy’s website!

@devil1591 it builds just fine for me with xcaddy:

$ xcaddy build --with --with

Hi Francis, I didn’t try on my machine, but it is broken on the website…

I think this is also broken

This topic was automatically closed after 90 days. New replies are no longer allowed.