Download Page broken

I wanted to download a Custom Build on the Download Page, but I cant select anything and get a jQuery Error:

Is the Download Page broken?

Works for me :man_shrugging:

Just tried using it, and it works for me…

Clear your cache? (But it hasn’t been changed in a couple weeks.)

Really Strange. On my Main PC it also works, but when I switch to my mobile or Surface Pro X2, the download buttons are not selectable :thinking:

Clearing the Cache didnt work, I tried it with 4 different Browsers (Chrome, Edge, Vivaldi and Firefox)

The problem happens on this line:

var platformParts = $('#platform').val().split("-");

If you could, try to figure out what happens to $('#platform') when the page loads. It should get set to your machine’s OS and architecture. You can put breakpoints in the download.js function autoPlatform to see what it does on page load using your browser’s dev tools.

1 Like

Hi Francis, thanks for the guidance. I’ve checked it and narrowed it down to ARM Devices. My Surface Pro X2 and Mi 10 Pro runs on ARM and the Plattform Code changes according to it:

With AMD64 it works (Tested on Windows and MacBook).

Sorry, I’m unclear on what you’re reporting. What does the value end up being on those platforms?

The source is here, if you have a particular change to propose to fix it:

This topic was automatically closed after 90 days. New replies are no longer allowed.