Disable SSL cert in Caddyfile

1. Caddy version (caddy version):

2.5.1

2. How I run Caddy:

I am using a Caddyfile to use my setup and I start it with caddy start

a. System environment:

Debian 11

b. Command:

caddy start

c. Service/unit/compose file:

d. My complete Caddyfile or JSON config:

https://subdomain.anonymousurl.com {
	reverse_proxy 127.0.0.1:9898
}

3. The problem I’m having:

Hi, I’d just like to know if there is a way to use a Caddyfile and ignore the SSL cert generation bit?

I have caddy behind a reverse proxy and I want this to handle all the SSL stuff

4. Error messages and/or full log output:

5. What I already tried:

I know I can just put http:// at the start of the domain and it won’t generate SSL, but I need to put in https:// because it’s what my reverse proxy is providing.

6. Links to relevant resources:

I ended up finding the solution;

“automatic_https”: {
“disable”: true / false,

It’s not possible to have Caddy receive an HTTPS connection without having a certificate to complete the TLS handshake. To do this, you’d need a TCP proxy, not an HTTP proxy. So you’d need to use GitHub - mholt/caddy-l4: Layer 4 (TCP/UDP) app for Caddy if you don’t want Caddy to terminate TLS.

1 Like