DigitalOcean DNS Provider Issues

I’m trying to install Caddy on CentOS 7.7 (Also had the same issues on Ubuntu 18.04). When starting the service I run into the error:

2019/09/29 01:00:10 [ERROR][*.my_domain.net] failed to obtain certificate: acme: Error -> One or more domains had a problem:

[*.my_domain.net] time limit exceeded: last error: read udp my_ip:33143->my_ip:53: read: connection refused

I’ve used a copy from the build server as well as built my own and received the same error.

During the attempt, I see the TXT record being created and it gets deleted before the service fails. I don’t have port 53 inbound open, nor do I have a DNS server running on this VM (fresh install).

Checked my DNS servers and put open DNS in resolve.conf (both IPv4 and IPv6).

I’ve been working on this trying to figure it out, and I’m sure its probably something simple that I’ve missed but I’m out of ideas. I’ve used lets encrypt through certbot previously and never had issues like this then again I don’t think I’ve used the dns challenge before.

I have resolved this issue, it was an issue with my NS records, however now I have the service starting and says its serving on https, but its not obtaining a certificate and is trying to serve the site without a certificate.

Hi @WizardTux, welcome to the Caddy community.

That shouldn’t be possible - it can’t serve a site without a certificate, Caddy should exit and give an error.

What’s your Caddyfile, and can you post a log of it starting up?