Can't use caddy with quic protocol

I want to test quic protocol with caddy.

1. What version of Caddy are you using (caddy -version)?


2. What are you trying to do?

try do test quic protocol.

3. What is your entire Caddyfile? {
root /home/zhaobo/web/caddy
log /tmp/caddy.log
tls /home/zhaobo/ca/root/intermediate/certs/ /home/zhaobo/ca/root/intermediate/private/

4. How did you run Caddy (give the full command and describe the execution environment)?

./caddy -quic

5. Please paste any relevant HTTP request(s) here.

Request URL:
Request Method:GET
Status Code:304
Remote Address:
Referrer Policy:no-referrer-when-downgrade

Request header:
accept-encoding:gzip, deflate, br
if-modified-since:Tue, 27 Feb 2018 11:06:34 GMT
user-agent:Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/64.0.3282.167 Safari/537.36

Reponse header:
alt-svc:quic=":8443"; ma=2592000; v=“38,37,36,35”
date:Tue, 27 Feb 2018 11:07:04 GMT

6. What did you expect to see?

I use tcpdump at, but I only see the tcp packet not udp packet. I use self-signed certificate and Chrome show web site is secured(display a lock in green color).

I have enabled quic in chrome according to user guide.

7. What did you see instead (give full error messages and/or log)?

I want to know why quic protocol is not used?How can I config caddy or chrome, then quic will be used?

Remember, this community only works when those who get help also give help. Thanks for participating!

I see you’re using an old version of Caddy. You’ll always have to use the latest version of Caddy to get QUIC, because Chrome only supports the latest version of QUIC.

Thanks for your reply, and I have downloaded 0.10.11 and tried it, but it still use tcp protocol, not quic. What’s wrong?

Caddy is runing in ubuntu 16.04Lts, and the version of chrome is 64.0.3282.186 which runs in win7(another machine).


After I have moved web site from ubuntu to win7, I find the quic protocol works. Then I use command “netstat” to show listening port: in ubuntu, caddy only listen “:::8443”(tcp6 and udp6), but in win7, caddy listen “” and “[::]:8443”(tcp and udp).

Ubuntu has multi ip addresses that are created by VMWare and docker. so the problem is multi ip?or ubuntu should listen “”?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.