Can't start caddyfile

1. Output of caddy version:

v2.6.2 h1:wKoFIxpmOJLGl3QXoo6PNbYvGW4xLEgo32GPBEjWL8o=

2. How I run Caddy:

CLI

a. System environment:

pi os lite 11 bull eye

b. Command:

caddy start

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane. -->

d. My complete Caddy config:

portainerchat.duckdns.org {
        reverse_proxy tailscale-ip:9000
}

3. The problem I’m having:

can't start caddy

4. Error messages and/or full log output:


2022/11/16 14:37:36.632 INFO    using adjacent Caddyfile
Error: loading initial config: loading new config: starting caddy administration endpoint: listen tcp 127.0.0.1:2019: bind: address already in use
Error: caddy process exited with error: exit status 1

5. What I already tried:

6. Links to relevant resources:

This means you already have another instance of Caddy running.

How did you install Caddy?

1 Like

In that case, please follow these instructions for using Caddy as a systemd service:

Don’t use caddy start, instead use sudo systemctl start caddy etc.

2 Likes