Can't install docker on Unraid

1. Caddy version (caddy version):

Latest via docker

2. How I run Caddy:

a. System environment:

Unraid Docker

b. Command:

CaddyV2 docker from Community Apps


HTTP: 1880
HTTPS: 18443
Data: /mnt/user/appdata/caddy/data
Config: /mnt/user/appdata/caddy/config
Caddyfile: /mnt/user/appdata/caddy/Caddyfile

c. Service/unit/compose file:


d. My complete Caddyfile or JSON config: {

3. The problem I’m having:

The docker entirely stopped working. I uninstalled it and now it won’t reinstall since it seems to be having issues with the paths in the Unraid docker manager.

4. Error messages and/or full log output:

root@localhost:# /usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name=‘CaddyV2’ --net=‘bridge’ -e TZ=“America/Los_Angeles” -e HOST_OS=“Unraid” -p ‘1880:80/tcp’ -p ‘18443:443/tcp’ -v ‘/mnt/user/appdata/caddy/data’:’/data’:‘rw’ -v ‘/mnt/user/appdata/caddy/config’:’/config’:‘rw’ -v ‘/mnt/user/appdata/caddy/Caddyfile’:’/etc/caddy/Caddyfile’:‘rw’ ‘caddy:alpine’
docker: Error response from daemon: OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “rootfs_linux.go:58: mounting “/mnt/user/appdata/caddy/Caddyfile” to rootfs “/var/lib/docker/btrfs/subvolumes/3965282d98e3bf290de3d29900a27dbd1c0d65feed733f60d43917dd710cadd5” at “/var/lib/docker/btrfs/subvolumes/3965282d98e3bf290de3d29900a27dbd1c0d65feed733f60d43917dd710cadd5/etc/caddy/Caddyfile” caused “not a directory”””: unknown: Are you trying to mount a directory onto a file (or vice-versa)? Check if the specified host path exists and is the expected type.

The command failed.

5. What I already tried:

Erased all files and attempted reinstall
Tried default install changing nothing

6. Links to relevant resources:

I think the error message is pretty self-explanatory. Are you sure your Caddyfile is actually a file, and not a directory?

Ultimately this is a Docker issue, not a Caddy issue.

OK, it took me far too long to realize that if the Caddyfile wasn’t there at all, it wouldn’t create it as a standard part of config.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.