Can't get wordpress site to work

### 1. Caddy version (`caddy version`):


### 2. How I run Caddy:

As a service on a raspberry pi4

#### a. System environment:


#### b. Command:

caddy run

#### c. Service/unit/compose file:


#### d. My complete Caddyfile or JSON config: {
reverse_proxy *
} {
reverse_proxy *
} {
reverse_proxy *
} {
root *
### 3. The problem I'm having:
<!-- What are you trying to do, and what isn't working? Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you're seeing. Be as specific as possible. -->

I use caddy as a reverse proxy for two synology nas’s and for homeassistant. These three just work. I also want to host a website from one of the synologies. I installed it correctly, I think. I tried to use the same reverse proxy command as with the other ones. That worked locally. in the browser, but returned the local URL From the outside world that doesn’t work. I then read one of Matt’s tutorials on this topic and changed the caddyfile to what you see above. It still returns the local URL.

I’ve been going through this forum, but can’t find the solution. I just am too much of a rookie to really understand the issue.

### 4. Error messages and/or full log output:

No errors in caddy. The browser quiery just times out.

### 5. What I already tried:

As I explained above. I’ve read through the forum and some tutorials to no avail.

### 6. Links to relevant resources:

This doesn’t look quite right. You actually have a directory on disk with a path that has an IP address?

The files must be accessible via the filesystem.

This is also not correct, you must specify unix/ as a prefix to the path to the unix socket file. It must also be accessible via the filesystem.

Please do not use PHP 5.6. That is a very old and insecure version of PHP. It’s completely irresponsible to run a site on such an old version of PHP. Please upgrade to at least PHP 7.4.

1 Like

I guess I made quite a mess. I use the synology standard installation. This requires several versions of php. I have seen tutorials on how to install wordpress from scratch. I guess I’ll do that first.

About the IP addresses. I’m not running caddy on the same machine as where I run the site. I thought it would be required to direct it to that machine. I’ll look into a clean install and take it from there.

Thank you for the tips. There is a lot to learn out there.

Your tips have helped me solve it. I threw out the synology packages and installed Mariadb and wordpress in docker. All the latest versions, so php 7.4. I now reverse proxy into it, no problem.


This topic was automatically closed after 30 days. New replies are no longer allowed.