Can't get caddy to work with Chrome "This site cannot be reached"

1. Caddy version:

docker-compose caddy:2.6.2

2. How I installed, and run Caddy:

docker compose

a. System environment:

docker compose

b. Command:

    image: caddy:2.6.2
      - "80:80"
      - "443:443"
      - "443:443/udp"
      - "444:444"
      - ./configs/caddy/Caddyfile:/etc/caddy/Caddyfile
      - ./configs/caddy/site:/srv
      - caddy_data:/data
      - caddy_config:/config
    restart: unless-stopped

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddy config: {
	redir /ui
	rewrite * /ubitest{uri}
	reverse_proxy node-red:1880

3. The problem I’m having:

I am using caddy as a proxy server to serve a node-red website (UIBuilder). At present I am testing on a lan network. Firefox works as expected. Chrome will not connect with message “This site cannot be reached”. Clicking the icon next to the address shows “Your connection to this site is not secure”. I have turned off safe browsing in settings > privacy & security > security as well as trying standard protection.

Firefox and Chrome as being used on macos Monterey.

4. Error messages and/or full log output:

Paste logs/commands/output here.

5. What I already tried:

6. Links to relevant resources:

Why are you publishing port 444? Caddy isn’t listening on that port (you haven’t configured it to do so).

This doesn’t make sense. Caddy listens on port 80 and 443, not 1880.

A redirect is a response telling the client “try again, but at this URL instead”.

This directive isn’t doing anything for you. Directives are sorted according to this directive order so reverse_proxy will always shadow file_server and it will never be reached. You can remove it.

You haven’t posted your logs. Please do so.

Enable the debug global option, as instructed by the help topic template. Then check your logs after making a request, and show us what you see in there.

SOLVED Chrome settings > Privacy & Security > Security > Advanced > Use secure DNS: Disable



Is that something you enabled yourself? Or is Chrome enabling that by default now?

It certainly makes sense that it would get around your local DNS configuration if you had any.

I think it is default but can’t be 100% sure.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.