Can't connect to subdomains under Caddy

1. Caddy version (caddy version):

v2.1.1 h1:X9k1+ehZPYYrSqBvf/ocUgdLSRIuiNiMo7CvyGUQKeA=

2. How I run Caddy:

go to /etc/caddy/ and run sudo caddy run or sudo caddy start

a. System environment:

Ubuntu 20.04.1 LTS, systemd

b. Command:



c. Service/unit/compose file:



d. My complete Caddyfile or JSON config:

} {
	encode gzip
		log {
			output file /etc/caddy/logs/jellyfin_access.log {
				roll true				# Rotate logs, enabled by default
				roll_size_mb 5			# Set max size 5 MB
				roll_gzip true			# Whether to compress rolled files
				roll_local_time true	# Use localhost time
				roll_keep 2				# Keep at most 2 log files
				roll_keep_days 7		# Keep log files for 7 days 
    redir /jellyfin /jellyfin/
    reverse_proxy /jellyfin/*
# Edit 05/06/20 Remove Empty Brackets, Change logging format, and added Email portion. Commented out email portion for now
# Edit 05/07/20 Removed Email portion. Adding an optional part in the guide for it.
# Proof /u/NoFeedback4007 is original author. :)

3. The problem I’m having:

When trying to connect to my media server via, it doesn’t connect to the server, only bringing me to a router login page of sorts.

4. Error messages and/or full log output:


5. What I already tried:

Made sure all ports are forwarded correctly, not sure what else to try.

6. Links to relevant resources:

What’s your router’s IP address? (like what address do you use to access the router’s admin panel?)

I can already tell this isn’t a Caddy problem – but something about your network or DNS is misconfigured. (The closest this would be to a Caddy problem is the address you’re proxying to in the config, but I’m guessing that’s not it since Jellyfin’s port is 8096.)

I have Mediacom WiFi, so I don’t use an actual IP, but rather

I’m not really sure what to change, or where I should even start

I do have the following ports forwarded under both TCP and UDP though: 80, 443, 8096, along with some others for other things.

Something’s not working with my DDNS, an IP connect will work, but not if I use my DDNS URL. I’m looking into it.

This topic was automatically closed after 30 days. New replies are no longer allowed.