Cannot sign in to DigitalOcean Droplet

1. My Caddy version (caddy -version):

v2.0.0-beta12

2. How I run Caddy:

  1. Deployed via DigitalOcean marketplace
  2. Received root password from DO in normal fashion
  3. Cannot login to droplet via ssh with supplied password

a. System environment:

DigitalOcean, Ubuntu 18.0.4

b. Command:

Deployed via marketplace

3. The problem I’m having:

Can’t login to caddy server via ssh with DigitalOcean supplied root password

4. Error messages and/or full log output:

login as: root
root@learn’s password:
Access denied

5. What I already tried:

  1. Tried to reset root password, no luck

You have to log in with your private key; password login is disabled (I think).

What private key? I deployed this from DigitalOcean Marketplace. There were no options to set a private key.

When you set up a droplet, an SSH key is the default and recommended option:

I believe we’ve disabled password login in our image for security reasons… I guess it’s not clear though if you choose one-time password whether they override that.

For now, probably best to just create the image using SSH key.

@jonwgeorge I guess DO doesn’t disable the password option on their Droplet Creation page even if the droplet forbids password logins. After discussing with @Mohammed90 it sounds like we may be changing our droplet to allow password login.

I searched: :computer::mag:

  1. Choose an SSH key, if you’ve added one. If you choose not to use SSH keys, your Droplet’s password will be emailed to you after creation.

Did you receive the email?

I guess I just glazed over that section… I’ve been using digital ocean for years but never used SSH keys. Might be time to update my practices… :thinking:

@jonwgeorge FYI, @Mohammed90 made some excellent enhancements to the DO image here: https://github.com/caddyserver/dist/pull/13 – including allowing root login (not our favorite, but oh well) – so we’ll update it, probably for beta 15 in the next week or two.