Cannot progress past finished cleaning storage units

1. Caddy version (caddy version):2.4.6

2. How I run Caddy:

a. System environment:

Windows 10 Pro

b. Command:

./caddy run

c. Service/unit/compose file:

N/A

d. My complete Caddyfile or JSON config:

sonarr.scottyydg.com {

	log {
		output file access.log {
        		roll_size 5MiB         
        		roll_keep_for 168h     
        		roll_keep 2            
        	}
	}

	reverse_proxy /sonarr/* {
		to localhost:8989
	}
}

3. The problem I’m having:

Basically, Caddy ran fully once, and ever since then it seems to hang on the ‘finished cleaning storage units’ without progressing even after several minutes.

4. Error messages and/or full log output:

PS C:\Caddy> ./caddy run
2022/01/10 22:18:22.026 ←[34mINFO←[0m using adjacent Caddyfile
2022/01/10 22:18:22.028 ←[33mWARN←[0m input is not formatted with ‘caddy fmt’ {“adapter”: “caddyfile”, “file”: “Caddyfile”, “line”: 2}
2022/01/10 22:18:22.032 ←[34mINFO←[0m admin admin endpoint started {“address”: “tcp/localhost:2019”, “enforce_origin”: false, “origins”: [“localhost:2019”, “[::1]:2019”, “127.0.0.1:2019”]}
2022/01/10 22:18:22.032 ←[34mINFO←[0m tls.cache.maintenance started background certificate maintenance {“cache”: “0xc000252770”}
2022/01/10 22:18:22.032 ←[34mINFO←[0m http server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS {“server_name”: “srv0”, “https_port”: 443}
2022/01/10 22:18:22.032 ←[34mINFO←[0m http enabling automatic HTTP->HTTPS redirects {“server_name”: “srv0”}
2022/01/10 22:18:22.032 ←[34mINFO←[0m tls cleaning storage unit {“description”: “FileStorage:C:\Users\scott\AppData\Roaming\Caddy”}
2022/01/10 22:18:22.033 ←[34mINFO←[0m http enabling automatic TLS certificate management {“domains”: [“sonarr.scottyydg.com”]}
2022/01/10 22:18:22.043 ←[34mINFO←[0m autosaved config (load with --resume flag) {“file”: “C:\Users\scott\AppData\Roaming\Caddy\autosave.json”}
2022/01/10 22:18:22.043 ←[34mINFO←[0m serving initial configuration
2022/01/10 22:18:22.044 ←[34mINFO←[0m tls finished cleaning storage units

5. What I already tried:

Restarted the machine, ensured the required ports are open, rewritten the config file a few different ways, both basic and verbose, tried to start it directly using --from and --to in the command line

6. Links to relevant resources:

N/A

That output is normal. What isn’t working? What do you mean by “without progressing”? There’s nothing left to do at startup.

Ah, my apologies. I thought I was missing something. I’m believing there to be an issue with something different in the chain, such as my cloudflare settings or something with Sonarr. Apologies for the issue, I’m rather noob-ish with a lot of this.

No worries. I think Caddy is just waiting to serve requests at that point. :man_shrugging: