CaddySSL is still not generating RSA keys instead of EC Kesy

Hello Mr. Matt,
It’s still not generated RSA key file instead of EC key, even though I added below code to my Caddyfile.

tls {
    key_type rsa2048
}

And my Caddyfile is now as below…

mydomain.com
{
  reverse_proxy 127.0.0.1:5000`
}
tls {
   key_type rsa2048
}

Please help me. Thank you in advance!

1. Caddy version (caddy version):

2. How I run Caddy:

a. System environment:

b. Command:

Paste command here.

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

{
        "sans": [
                "mydomain.com"
        ],
        "issuer_data": {
                "url": "https://acme-v02.api.letsencrypt.org/acme/cert/04---aee8f5-----a3e83c--acafbf5"
        }
}

Paste config here, replacing this text.
Use caddy fmt to make it readable.
DO NOT REDACT anything except credentials.
LEAVE DOMAIN NAMES INTACT.
Make sure the backticks stay on their own lines.


### 3. The problem I'm having:
<!-- What are you trying to do, and what isn't working? Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you're seeing. Be as specific as possible. DO NOT USE WEB BROWSERS; use "curl -v" instead. -->

-----BEGIN EC PRIVATE KEY-----
MHcCAQEEIMnb5yhMoHQkhZlglH94c2wLE9SBh2YX+MaK76lx+3/YoAoGCCqGSM4


### 4. Error messages and/or full log output:
<!-- Please **DO NOT REDACT** any information except credentials. Leave domain names intact! -->
<!-- Please **DO NOT POST TRUNCATED LOG LINES** as systemd is notorious for this. -->
<!-- Please **DO NOT USE WEB BROWSERS.** Use curl -v instead. -->
<!-- Please **DO ENABLE DEBUG MODE FIRST** by adding "debug" to the global options of your Caddyfile. -->


### 5. What I already tried:
<!-- Show us what effort you've put in to solving the problem. Be specific -- people are volunteering their time to help you! Low effort posts are not likely to get good answers! -->



### 6. Links to relevant resources:

Please see how the Caddyfile is structured:

Directives go within site blocks, not outside.

Next time, please properly follow the topic template, and do not ignore any sections.

1 Like

Super Sir,

It’s working very wonderfully more than my expectations with the same CaddySSL after I made a change to it.

A Heartfelt thanks to Mr.Matt for his straight solution and you too!

1 Like

Hi Sir,

I have added 3 mx records under DNS zones for MTA-STS. I’ve been struggling a lot to enable MTA-STS for my website. But, it’s still seems to be wrong.

So could you please let me have your guidance on how to make it done in a right way since I used in below lines in my Caddyfile and nothing worked for me.

mydoamin.com
{
 tls....{ ....}
}
mta-sts.mydomain.com {

respond "version: STSv1
mode: testing
mx: mail.mydomain.com
max_age: 86401"
header Content-Type "text/plain; charset=utf-8"

}

Many thanks in advance for your quick response.!

Kind Regards,
Xeny

Hello,
Can anyone help me with a solution for this, please? Thank you in advance!