Caddy2 reverse proxy changes address in browser

1. Caddy version 2

2. How I run Caddy:

a. OS : Windows10 f

b. Command: caddy run

c. Service/unit/compose file:

reverse_proxy {
to localhost:5000
header_up Host {}

#### d. localhost {
reverse_proxy {
to localhost:5000
header_up Host {}



### 3. The problem I'm having:
I am using caddy as reverse proxy for my core application. I am new to caddy webserver. core demo application running on port 5000**
when i type localhost in my browser it is showing localhost:5001 and the links are showing https://localhost:5001/Home/Privacy  (ex : privacy link)
I don't wanted to display like that i wanted display as https://localhost/Home/Privacy

Am i missing something ..? or my caddy file is incorrect ..? or is this a issue in caddy..? Please correct me

### 4. Error messages and/or full log output:
<!-- Please **DO NOT REDACT** any information except credentials. -->
<!-- Please **DO NOT POST TRUNCATED LOG LINES** as systemd is notorious for this. -->

### 5. What I already tried:

### 6. Links to relevant resources:
I rasied issue here but it is closed since they aske me to contact in forum
Please help

To use code formatting, the ``` should go on their own lines, before and after the content.

Please fix the formatting of your post, it’s very hard to follow.

Have you tried making requests with curl -v in your terminal, as Matt suggested? What’s the output?

I am able to manage run my core application using caddy2 as reverse proxy
If some body wants this as a reference . below is the url for that sample application at main · ironpython2001/ · GitHub

This topic was automatically closed after 30 days. New replies are no longer allowed.