Caddy with duckdns not working

1. The problem I’m having:

I have a problem of not able to access my jellyfin server with caddy and duckdns outside home network.

I installed jellyfin (docker), using port 8096 (http) and 8920 (https). I created some domains in duckdns and points towards my router’s public ip address ( I have forwardded 8123, 80, 443, 8096, 8920, etc in router to my home server ip addresses.
Now, the is working within home network but not from outside

These are the steps:

  1. Register a domain in say points to my public ip
  2. Install jellyfin docker and run it. (8096 and 8920 for http/s respectively) localhost:port works fine
  3. Install Caddy. create Caddyfile with this content:
  1. using browser, jellyfin clients, check if works. It works, in internal/home network
  2. Disconnected mobile from home network and tried to open It doesnt work.

2. Error messages and/or full log output:

Page does not open in external network.

3. Caddy version:


4. How I installed and ran Caddy:

I installed caddy with apt package manager. I installed xcaddy using binary and used

xcaddy build --with

to install duckdns module

I ran caddy using

sudo caddy start --config ./Caddyfile

Caddyfile location is correct

a. System environment:

b. Command:

Please use the preview pane to ensure it looks nice.

c. Service/unit/compose file:

Please use the preview pane to ensure it looks nice.

d. My complete Caddy config:

5. Links to relevant resources:

You should not be using caddy start to run Caddy.

Use the systemd service instead:

Also, follow these instructions to swap out the apt repo binary with your custom one:

When going to I’m seeing Caddy’s default startup page. This tells me that Caddy is running on your server, but with the default configuration. Make sure you edit /etc/caddy/Caddyfile.

Did both. Running caddy start and using systemctl both works similar.

I found something in this. I initially had port forwarded 80 and 443 with TCP. When I enabled both TCP and UDP, it sort of works outside my home network. But not guarenteed. It works sometimes, then it doesn’t. no longer has a valid IP address. You must have changed something.

Anyway, the problem is that using caddy start will run Caddy as the wrong user, and will not automatically start when your server reboots.

Like I said, make sure you’re using the systemd service. Show your service’s logs if you’re still having trouble.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.