Caddy version output changed to a simple v1.0.4

1. My Caddy version (caddy version):


2. How I run Caddy:

from terminal

a. System environment:

Ubuntu 18.04.4 LTS

b. Command:

./caddy -version

d. My complete Caddyfile or JSON config:


3. The problem I’m having:

I noticed that the output of ./caddy -version of a caddy that I downloaded a week ago is

Caddy v1.0.4 (h1:wwuGSkUHo6RZ3oMpeTt7J09WBB87X5o+IZN4dKehcQE=)

However, the output of ./caddy -version of a caddy that I downloaded today is simply


I am using the same machine and running the commands in the same terminal.

So I wonder if my download was compromised.

4. Error messages and/or full log output:

5. What I already tried:

File size is the same, md5 changed:

test@lxsrv2:/tmp/test/older$ ./caddy -version
Caddy v1.0.4 (h1:wwuGSkUHo6RZ3oMpeTt7J09WBB87X5o+IZN4dKehcQE=)
test@lxsrv2:/tmp/test/older$ ls -l ./caddy
-rwxr-xr-x 1 test test 21953868 Mär 18 06:59 ./caddy
test@lxsrv2:/tmp/test/older$ md5sum ./caddy
983957ac1f8503dae59a8d8cb039f154 ./caddy

Remark: I performed a scp to copy the older version to the same machine. Thus today’s date. Original date on the other machine is 21953868 Mar 8 17:44 /usr/local/bin/caddy.

Here the caddy, that I downloaded today:

test@lxsrv2:/tmp/test/today$ ./caddy -version
test@lxsrv2:/tmp/test/today$ ls -l ./caddy
-rwxr-xr-x 1 test test 21953868 Mär 10 07:21 ./caddy
test@lxsrv2:/tmp/test/today$ md5sum ./caddy
2640047353ec39e4150ba2b717b755f6 ./caddy

I performed various downloads via browser using the Download button and via wget:

wget --content-disposition ""

I got the same result. Todays’s output remains simply v1.0.4

However, I am not sure if I performed the download a week ago using the same wget command.

6. Links to relevant resources:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.