Caddy v2 Cloudflare plugin install

1. Caddy version (caddy version):


2. How I run Caddy:

a. System environment:


b. Command:

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:

paste config here, replacing this text
DO NOT REDACT anything except credentials

3. The problem I’m having:

I want to install caddy v2 with cloudflare

4. Error messages and/or full log output:

2020/06/13 19:46:49 [INFO] Temporary folder: /tmp/buildenv_2020-06-13-1946.140419163
2020/06/13 19:46:49 [INFO] Writing main module: /tmp/buildenv_2020-06-13-1946.140419163/main.go
2020/06/13 19:46:49 [INFO] Initializing Go module
2020/06/13 19:46:49 [INFO] exec (timeout=10s): /snap/bin/go mod init caddy
go: creating new go.mod: module caddy
2020/06/13 19:46:49 [INFO] Pinning versions
2020/06/13 19:46:49 [INFO] exec (timeout=0s): /snap/bin/go get -d -v
go: upgrade => v2.0.0
2020/06/13 19:46:51 [INFO] exec (timeout=0s): /snap/bin/go get -d -v GitHub - caddy-dns/cloudflare: Caddy module: dns.providers.cloudflare
go get https:/ malformed module path “https:/”: invalid char ‘:’
2020/06/13 19:46:52 [FATAL] exit status 1

5. What I already tried:

Follow this How to use DNS provider modules in Caddy 2

6. Links to relevant resources:

and I am an idiot. I used https. sorry about that

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.