Caddy v2: Can't access file in webdav

1. Caddy version (caddy version):

v2.1.1 h1:X9k1+ehZPYYrSqBvf/ocUgdLSRIuiNiMo7CvyGUQKeA=

2. How I run Caddy:

caddy start -config /etc/caddy/Caddyfile

a. System environment:

LEDE V2.31

b. Command:

paste command here

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:

http_port 80
https_port 90
order webdav last
root * ./
encode gzip
webdav /dav {
root ./
prefix /dav
tls /mnt/sdb5/ssl/uhttpd.crt /mnt/sdb5/ssl/uhttpd.key
basicauth {
qewqw JDJhJDEwJGlSb0RFdWdMdThuMC55L2s4RS4uTk1DNk1XWG9SV1hzUW42SUlyc043dXZPVWE1YzZt
reverse_proxy /
paste config here, replacing this text
DO NOT REDACT anything except credentials

### 3. The problem I'm having:
<!-- What are you trying to do, and what isn't working? Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you're seeing. Be as specific as possible. -->

I built a webdav server. I can log in to the service. But after I log in it, I can't access any file.

### 4. Error messages and/or full log output:
<!-- Please **DO NOT REDACT** any information except credentials. -->
caddy doesn;t give any error message.
When I use chrome: :Method Not Allowed
When I use windows10 's network location: 0x80070057 

### 5. What I already tried:
<!-- Show us what effort you've put in to solving the problem. Be specific -- people are volunteering their time to help you! Low effort posts are not likely to get good answers! -->

### 6. Links to relevant resources:

I answered here:

Also please wrap your config with ``` to use code formatting.

This topic was automatically closed after 30 days. New replies are no longer allowed.