Caddy v2: Cachet status page help with Caddyfile

1. Caddy version (caddy version):

v2.0.0 h1:pQSaIJGFluFvu8KDGDODV8u4/QRED/OPyIR+MWYYse8=

2. How I run Caddy:

Installed from the repository

a. System environment:


Ngix Config

server {

  listen 80;
  listen [::]:80;


  root /var/www/cachet/public;

  index index.php;

  ssl_certificate /etc/letsencrypt/;
  ssl_certificate_key /etc/letsencrypt/;
  ssl_certificate /etc/letsencrypt/status.example.com_ecc/fullchain.cer;
  ssl_certificate_key /etc/letsencrypt/status.example.com_ecc/;

  location / {
    try_files $uri /index.php$is_args$args;

  location ~ \.php$ {
    include fastcgi_params;
    fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_index index.php;
    fastcgi_keep_conn on;


My actual Caddyfile (Don’t works)

:80 {
    root * /var/www/cachet/public

    php_fastcgi unix//run/php/php7.3-fpm.sock

What doesn’t work? We can’t help if all you say is “don’t works”.

Please elaborate. What do you see in your logs? What do you see in your browser?

It is very strange I only got the blank page. After turning it off and on again the VM worked.

This topic was automatically closed after 30 days. New replies are no longer allowed.