Caddy v2 b13 not working on Windwos Server 2016

1. My Caddy version (caddy -version):

v2 b13

2. How I run Caddy:

Please provide all of the relevant information and DO NOT REDACT anything except passwords/keys. Thank you!

Windows command prompt

a. System environment:

OS, relevant versions, systemd? docker? etc.

Windows server 2016

b. Command:


c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile:

root * /www/

3. The problem I’m having:

Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you’re seeing. Be as specific as possible.
Does not run in Windows server 2016

4. Error messages and/or full log output:

Please DO NOT REDACT any information except passwords/keys.

This app can’t run on your PC

5. What I already tried:

Caddy v2 b12 is fine

6. Links to relevant resources:

I recently signed up with Vultr to test Caddy and was getting unusable credit.
It is a good opportunity to test Caddy on Windows Server 2016.
I immediately tried it.

But without seeing that message, Caddy is working fine:

Hopefully the problem can be avoided with the settings. Or try launching from PowerShell.

This is working now. I just checked the file and it was 0 kb in size so the file didn’t even download properly, downloaded again and is fine. Sorry about that.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.