Caddy server worked but unable to access through Chrome

Hi everyone,
I’m new to the networking field as well as caddy. I tried to setup caddy -quic server on one Linux computer (Ubuntu 16.04.3 LTS) and then using chrome on other linux to access to the caddy server on the first computer. At the same time I tried to use Wireshark to capture packets which use QUIC protocol.
Here is the Caddyfile on the first computer, I’m using caddy v1.0.0 :

emuquic.com:443
{
       tls {
       max_certs 10
}
}

when I type ‘’ caddy-quic" I got this on terminal:

**Dispelk9@server** : **~** $ caddy -quic

Activating privacy features... done.

Serving HTTP on port 80

http://emuquic.com

Serving HTTPS on port 443

https://emuquic.com

When I tried to connect using Chrome on the second computer. It shows that this site cannot be reached (ERR_NAME_NOT_RESOLVED) on tab emuquic.com

and

this site cannot be reached (DNS_PROBE_FINISHED_NXDOMAIN) on tab https://emuquic.com

Any helps are appreciated.

Hi @Hoang_Viet, welcome to the Caddy community.

emuquic.com is not a currently registered domain.

To serve a website from a domain name, you must first register that domain and then configure nameservers to point visitors to your web server.

@Whitestrake thanks for your reply. So how can I active Caddy server with Quic enabled on localhost? I can do that without a registered domain or not?

In this post, someone said that to enable quic I need a domain name. https://github.com/caddyserver/caddy/issues/2194

Do I need a certificate key from CA, which both are made locally. Or I can simply use max_cert 10 for Quic?

max_cert tells Caddy to requisition valid certificates from LetsEncrypt whenever someone tries to connect. This is the On-Demand TLS feature. It still requires a valid domain name. It works exactly like regular managed TLS, it just delays the certificate acquisition until client connections come in.

QUIC requires a valid domain name, SNI, and a valid certificate (i.e. not self-signed). You need to get a real domain and point it at your server.