Caddy Reverse Proxy for Tomcat 8.5

first of: nice webserver!

really love the let’s encrypt integration :slight_smile:

trying to setup caddy as reverse proxy for apache-tomcat-8.5.50.tar.gz

is my caddy config not seem valid proxy config anymore?

1. My Caddy version (caddy -version):

caddy -version
Caddy v1.0.4 (h1:wwuGSkUHo6RZ3oMpeTt7J09WBB87X5o+IZN4dKehcQE=)

2. How I run Caddy:

Please provide all of the relevant information and DO NOT REDACT anything except passwords/keys. Thank you!

a. System environment:

Operating System: CentOS Linux 8 (Core)
CPE OS Name: cpe:/o:centos:centos:8
Kernel: Linux 4.18.0-147.3.1.el8_1.x86_64
Architecture: x86-64

OS, relevant versions, systemd? docker? etc.
… no docker.

b. Command:

runuser -l caddy -c '/usr/local/bin/caddy -conf /usr/local/bin/caddy -conf /etc/caddy/caddy.proxy.websocket.transparent.config'

paste command here

#### c. Service/unit/compose file:

paste full file contents here

#### d. My complete Caddyfile:

h tt p s : / /  d om a {
    proxy / {

# this works: (but picture urls are like:
d o m a i n . com
proxy /

paste Caddyfile here
DO NOT REDACT anything except credentials

3. The problem I’m having:

… it just times out: 502 Bad Gateway

Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you’re seeing. Be as specific as possible.

4. Error messages and/or full log output:

Please DO NOT REDACT any information except passwords/keys.

5. What I already tried:

6. Links to relevant resources:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.