Caddy is running port 80 is open but it suddenly got unreachable from web

1. Caddy version (caddy version):

v2

2. How I run Caddy:

everything worked fine to stream my jellyfin server for abouth 3 months. suddenly stopped after an apt-get upgrade I think. but at this time i’m about 8 hours in of troubleshooting and still found nothing.

a. System environment:

ubuntu desktop 20.04

b. Command:

I use caddy as a service in systemctl. It worked right a the beginning ( 3 months ago )

Paste command here.

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

since I purged it and reinstall it everything is ‘default’

Paste config here, replacing this text.
Use `caddy fmt` to make it readable.
DO NOT REDACT anything except credentials.
LEAVE DOMAIN NAMES INTACT.
Make sure the backticks stay on their own lines.

3. The problem I’m having:

listened hours and hours of movies remotely on jellyfin via caddy during 3 months untill yesterday. I cant even reach the default ‘‘Caddy’s working’’ site ( with the default Caddyfile)

4. Error messages and/or full log output:

no error messages.

5. What I already tried:

–ports are opened and caddy is listening (used portchecker)
–firewall disabled
–systemctl status caddy reveal no errors and tell that everything is running fine (default
on :80 OR on SSL via a ddns.net address port 443 )
–looked if there is some ports conflicting each other and its look like nothing is in conflicting
–been searching on reddit github forums and so on for about 3-4 hours but caddy seems to be still relatively ‘new’ to community so havent found anything that helped me so far.
– seems like and apt-get upgrade messed up something

6. Links to relevant resources:

strangely it seems like it is back on magically…lol

on the default Caddy works! at least. Will let you know when my reverse-proxy will be on.

Please fill out the help template, or we can’t help you. :pensive:

after some testing it looks like it doesnt work but only when I am on my local network. remotely it works. Was at my office this morning and suprisingly it worked like a charm. But when I got home, stopped working. When I put my phone on LTE I can reach my server but as soon as I connect it to my wifi network it doesnt work.

found a thread about another user on caddy.community. seems like it is an hairpin NAT. how I can resolve this ^