Caddy Installation Help

1. My Caddy version (caddy version):

I’m looking to install Caddy Version 2. Still no luck doing so on an EC2 instance on AWS.

a. System environment:

Ubuntu 16.04 but I can use any Linux build.

3. The problem I’m having:

The problem I’m having is instructions are either outdated or not working. I think Caddy is incredible and I’ve spent countless hours playing with it. But, some basics I’m still struggling with like how to see the logs to know why I’m getting errors like: “Failed to start Caddy HTTP/2 web server.”

5. What I already tried:

I have tried following every doc online and they all seem a bit too vague or for version 1. For example: Getcaddy.com

Following these instructions is either not working or I’m doing something wrong: Install — Caddy Documentation

I was hoping there is an actual comprehensive tutorial how to install this on AWS. Using the DigitalOcean droplet worked like a charm, but I’d rather be on AWS using an EC2 with Elastic File System. It’s where all my other servers are.

I’m not looking to be baby sat through this. Really just need some pointers since the docs are at the moment very condensed without a single extra word or tip along the way.

I’m not a linux or Go expert and its possible this is really above me. But the instructions say something like Buid From Source with 3 very simple instructions. Obviously this didn’t work for me, but then I have no where else to read more.

Any tips or pointers would be greatly appreciated.

In general, for the time being, the best way to get Caddy v2 is to download the release from GitHub. The first link at the top of the Install docs page (static binary) is a link to the GitHub releases. Maybe you didn’t realize you need to expand the “Assets” section at the bottom of each release to see the downloadables?

Note that there is a regression in RC2 that causes a panic (crash) in some pretty common situations. If you run into it, you can use the latest CI artifact here instead: Fix some godocs · caddyserver/caddy@68cebb2 · GitHub

I’m not sure what other help to offer, because your question is very vague. If you can be more specific about what problems you’re running into, we’ll be able to help more effectively.

You say things like “Obviously this didn’t work for me” but that doesn’t tell us anything about what problems you actually encountered, so otherwise we’d need to guess every possible problem that might’ve happened.

2 Likes

Thanks for your help.

So the assets is where its at and for some dumb reason I didn’t realize that where to look. Took me a bunch more hours but eventually I did figure this out and got it running on EC2 instance.

I’ve been taking screenshots and I’ll try and write a doc for users like myself who are really not great at working with linux.

I have one more question for you, if you don’t mind.

Using the Caddyfile are you able to point me to how I can change the location of where the certificates are stored?

I want it to be something like: “/home/ubuntu/efs” instead of the default. I see some docs on here on setting storage.

Is it supposed to look like this:

{
storage file_system {
/home/ubuntu/efs
}
}

I think the correct config is:

{
  storage file_system {
    root /home/ubuntu/efs
  }
}

The docs for the file_system module is here (JSON config):

You can test it like this, to confirm that it gives the right output:

$ ./caddy2 adapt --config Caddyfile
{"storage":{"module":"file_system","root":"/home/ubuntu/efs"},"apps":{"http":{"servers":{"srv0":{"listen":[":80"]}}}}}

@matt interestingly, you can replace root with any other word and it still works :joy: we’re not validating the option name in filestorage.go UnmarshalCaddyfile

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.