Caddy in LAN, has a big issue


(熊宝) #1

Your know, in China home network 80 & 8080 port is disabled. But the 443 port available.
If I want create a website on my home PC, can only be used 443(HTTPS).
Also, in the LAN must be used port forwarding on router. forwarding to my webserver PC.

Then my networkis like this

  1. domain used DDNS to public ip.
  2. on router forwarding 443 to server pc(windows server 2008).
  3. no 80 no 8080, had to used tls realize domain verification.

Used IIS+SSL certificate(issued by TrustAsia TLS RSA CA), running ok external network accessible.

image
image

Stop IIS Used Caddy, port listening ok, ssl certificate is ok.

image

image

Caddyfile:
image

Log:
image

But Caddy doesn’t seem to be successful. the domain cannot be accessed.

What is the issue? How to solve?
Thanks.


(Matthew Fay) #2

Is there a firewall rule for Caddy?

I believe IIS sets its own Windows Firewall rules, but Caddy is more platform-agnostic and doesn’t configure platform specific settings like that.


(熊宝) #3

I tried adding a firewall rule(inbound&outbound), but still can not accessible.


(熊宝) #4

This issue solved, must add the application firewall option in the control panel.