Caddy hangs at "Trying to solve HTTP-01"

Until today Caddy has been chugging along nicely and serving several virtual hosts. After a software update and a restart Caddy would no longer start. Only one site was causing the problem, and I was able to isolate it easily.

Here’s my Caddyfile: {
  root /home/user/public

And here’s what happens when I launch Caddy:

user@localhost:~/caddy$ ./caddy -log stderr
Activating privacy features...2016/09/25 12:51:30 [INFO] Certificate for [] expires in 286h20m29.967139873s; attempting renewal
2016/09/25 12:51:30 [INFO][] acme: Trying renewal with 286 hours remaining
2016/09/25 12:51:30 [INFO][] acme: Obtaining bundled SAN certificate
2016/09/25 12:51:30 [INFO][] acme: Could not find solver for: tls-sni-01
2016/09/25 12:51:30 [INFO][] acme: Trying to solve HTTP-01

At this point it just hangs and I haven’t seen it go any further.

Any idea what’s causing the issue? It was serving HTTPS fine before, but now it seems it can’t renew the certificate. This is on a well-connected Ubuntu 14.04 VPS and Caddy 0.8.2.

As a temporary workaround I have switched to HTTP for this virtual host. But I’m afraid I could face the same issue with the other hosts.

Upgrade Caddy. :wink: Then try again.

Ah, thanks. That fixed it. Should have tried that. :slight_smile: I guess I mistakenly thought the issue was something else.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.