Caddy failing TLS challenges

1. Caddy version (v2.4.6):

2. How I run Caddy:sudo caddy start

a. System environment: Archlinux, systemd, installed via arch user repository

b. Command:

sudo caddy start

c. Service/unit/compose file:I dont start it as service

I dont start it as service

d. My complete Caddyfile or JSON config: {
	encode gzip
	log {
		output file C:\caddy\logs\emby_access.log {
			roll true # Rotate logs, enabled by default
			roll_size_mb 5 # Set max size 5 MB
			roll_gzip true # Whether to compress rolled files
			roll_local_time true # Use localhost time
			roll_keep 2 # Keep at most 2 log files
			roll_keep_days 7 # Keep log files for 7 days 

3. The problem I’m having:

im using duckdns, it is pointed at my ip adress, im using this for a jellyfin server, whenever i run caddy i get this error msg (in step 4)

anyone know why im failing challenges, i tried the same methods on my main pc and it works perfectly fine.
the 80 and 443 ports are open on the ip addy

4. Error messages and/or full log output:[jelly@server:~]$ sudo caddy run -

5. What I already tried:rebooting pc,

using one-liner caddy script
using different duckdns domains
trying on different pc (works)
but nothing doing none of these worked.
also, when starting caddy on my main pc, ports 80 and 443 show as open, but on my server pc they show as closed

6. Links to relevant resources:

I strongly recommend that you do run Caddy as a systemd service.

Running with sudo caddy start means that Caddy runs as root (not ideal) and that it won’t automatically restart along with your system, and you lose Caddy’s log output which it emits to stdout/stderr.

The caddy start command is meant for quick-and-easy one-off servers, not for long-term use.

You need to port forward 80 and 443 to your server PC, not to your main PC.

This topic was automatically closed after 30 days. New replies are no longer allowed.