Caddy download with cloudflare DNS provider Windows

1. The problem I’m having:

I downloaded the Windows binary from the website and included the cloudflare dns provider module in my selections. However when I run caddy from the command prompt it claims that the module could not be found. Also when running caddy list-modules I also cannot locate it in the list.

2. Error messages and/or full log output:

2024/03/22 23:19:59.770 ←[34mINFO←[0m   using provided configuration    {"config_file": "Caddyfile", "config_adapter": ""}
Error: adapting config using caddyfile: parsing caddyfile tokens for 'acme_dns': getting module named 'dns.providers.cloudflare': module not registered: dns.providers.cloudflare, at Caddyfile:2

3. Caddy version:

2.7.6

4. How I installed and ran Caddy:

Downloaded from https://caddyserver.com/download, copied to Windows machine and executed using caddy.exe run --config Caddyfile

a. System environment:

Windows 10 x64 22H2

b. Command:

caddy.exe run --config Caddyfile

c. Service/unit/compose file:

n/a

d. My complete Caddy config:

{
acme_dns cloudflare redacted
}	
emby.volt-amps.com {
    reverse_proxy 127.0.0.1:8096
}
sonarr.volt-amps.com {
    reverse_proxy 192.168.50.64:8989
}
radarr.volt-amps.com {
    reverse_proxy 192.168.50.64:7878
}
dl.volt-amps.com {
    reverse_proxy 192.168.50.64:8775
}

5. Links to relevant resources:

Ok I think I figured out a workaround using caddy add-package. For some reason I still cannot get it to respond to requests.

Are you sure you selected the Cloudflare plugin when you did that? Clearly the build you downloaded doesn’t have the plugin.

What’s the problem? Please elaborate. Show your logs.

After a lot of wasted time I discovered my public IP had changed. I hadn’t yet set up DDNS updates to cloudflare so.

I do think the download was a problem. Caddy works much better now and it might be helpful to include that note for those that are noobs at this. I must have downloaded from the download site a dozen times and could not get the module to show.

Cheers!

I’m not sure I follow. Are you sure you actually selected the plugin before clicking Download? If you right-click and copy the link on the Download button, you should see the plugin in the URL.

I am 1000% sure that I selected it. I even tried with multiple others that I didn’t need. The size of the exe was bigger, but I could not get it to recognize the additional modules.

In any case I’ve figured out a work around.

You can run .\caddy.exe list-modules to see what plugins are included in the binary you have downloaded. Are you sure you were actually running the one you downloaded? Did you forget to rename the binary after downloading?

Yes. I even downloaded it again and it showed 0 non-standard modules. No I didn’t forget to rename it as per the command I ran.