caddy configuration error

Hi I’m using Caddy 2 on home assistant for the first time, but I can’t get it to work, I am attaching the information:

s6-rc: info: service s6rc-oneshot-runner: starting
s6-rc: info: service s6rc-oneshot-runner successfully started
s6-rc: info: service fix-attrs: starting
s6-rc: info: service fix-attrs successfully started
s6-rc: info: service legacy-cont-init: starting
cont-init: info: running /etc/cont-init.d/00-banner.sh

Add-on: Caddy 2
Open source web and proxy server with automatic HTTPS

Add-on version: 1.2.5
You are running the latest version of this add-on.
System: Home Assistant OS 9.3 (aarch64 / raspberrypi4-64)
Home Assistant Core: 2022.11.2
Home Assistant Supervisor: 2022.10.2

Please, share the above information when looking for help
or support in, e.g., GitHub, forums or the Discord chat.

cont-init: info: /etc/cont-init.d/00-banner.sh exited 0
cont-init: info: running /etc/cont-init.d/01-log-level.sh
Log level is set to INFO
cont-init: info: /etc/cont-init.d/01-log-level.sh exited 0
s6-rc: info: service legacy-cont-init successfully started
s6-rc: info: service legacy-services: starting
services-up: info: copying legacy longrun caddy (no readiness notification)
s6-rc: info: service legacy-services successfully started
INFO: Prepare Caddy…
INFO: Use built-in Caddy
v2.6.2 h1:wKoFIxpmOJLGl3QXoo6PNbYvGW4xLEgo32GPBEjWL8o=
INFO: Prepare Caddyfile…
INFO: Caddyfile found at /config/caddy/Caddyfile
INFO: Run Caddy…
{“level”:“info”,“ts”:1668248974.5177932,“msg”:“using provided configuration”,“config_file”:“/config/caddy/Caddyfile”,“config_adapter”:“”}
{“level”:“warn”,“ts”:1668248974.522011,“msg”:“Caddyfile input is not formatted; run the ‘caddy fmt’ command to fix inconsistencies”,“adapter”:“caddyfile”,“file”:“/config/caddy/Caddyfile”,“line”:3}
{“level”:“info”,“ts”:1668248974.5553384,“logger”:“admin”,“msg”:“admin endpoint started”,“address”:“localhost:2019”,“enforce_origin”:false,“origins”:[“//localhost:2019”,“//[::1]:2019”,“//127.0.0.1:2019”]}
{“level”:“info”,“ts”:1668248974.556781,“logger”:“http”,“msg”:“server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS”,“server_name”:“srv0”,“https_port”:443}
{“level”:“info”,“ts”:1668248974.5568624,“logger”:“http”,“msg”:“enabling automatic HTTP->HTTPS redirects”,“server_name”:“srv0”}
{“level”:“info”,“ts”:1668248974.5568924,“logger”:“tls.cache.maintenance”,“msg”:“started background certificate maintenance”,“cache”:“0x40003d48c0”}
{“level”:“info”,“ts”:1668248974.5569386,“logger”:“http”,“msg”:“enabling automatic HTTP->HTTPS redirects”,“server_name”:“srv1”}
{“level”:“info”,“ts”:1668248974.559371,“logger”:“tls”,“msg”:“cleaning storage unit”,“description”:“FileStorage:/ssl/caddy”}
{“level”:“info”,“ts”:1668248974.559505,“logger”:“tls”,“msg”:“finished cleaning storage units”}
{“level”:“info”,“ts”:1668248974.5602028,“logger”:“http”,“msg”:“enabling HTTP/3 listener”,“addr”:“:443”}
{“level”:“info”,“ts”:1668248974.561267,“logger”:“http.log”,“msg”:“server running”,“name”:“srv0”,“protocols”:[“h1”,“h2”,“h3”]}
{“level”:“info”,“ts”:1668248974.562042,“logger”:“http”,“msg”:“enabling HTTP/3 listener”,“addr”:“:9000”}
{“level”:“info”,“ts”:1668248974.5626802,“logger”:“http.log”,“msg”:“server running”,“name”:“srv1”,“protocols”:[“h1”,“h2”,“h3”]}
{“level”:“info”,“ts”:1668248974.5631325,“logger”:“tls.cache.maintenance”,“msg”:“stopped background certificate maintenance”,“cache”:“0x40003d48c0”}
Error: loading initial config: loading new config: http app module: start: listening on :80: listen tcp :80: bind: address already in use
WARNING: Caddy 2 crashed, halting add-on
s6-rc: info: service legacy-services: stopping
INFO: Caddy 2 stoped, restarting…
s6-rc: info: service legacy-services successfully stopped
s6-rc: info: service legacy-cont-init: stopping
s6-rc: info: service legacy-cont-init successfully stopped
s6-rc: info: service fix-attrs: stopping
s6-rc: info: service fix-attrs successfully stopped
s6-rc: info: service s6rc-oneshot-runner: stopping
s6-rc: info: service s6rc-oneshot-runner successfully stopped

(https_header) {
header {
Strict-Transport-Security “max-age=31536000; includeSubdomains”
X-XSS-Protection “1; mode=block”
X-Content-Type-Options “nosniff”
X-Frame-Options “SAMEORIGIN”
Referrer-Policy “same-origin”
}
}

https://…duckdns.org {
respond “Saluti dal Crew inDomus”
file_server
}
https://…duckdns.org:9000 {
import https_header
reverse_proxy http://192.168.178.101:8123
}

I followed the guide of “Indomus” (Installare e configurare Caddy (reverse proxy) su Home Assistant OS/Supervised - inDomus.it)

Please fill out the help template. You see it when you’re creating a new thread under “Help” category.

Here’s your issue

You have another web server on your machine listening on port 80.

so how can i solve?

do you have any advice?

I checked the ports in use, but the 80 is not used by anyone

Please fill out the help template for us to be able to help you efficiently