Caddy 2 with apache virtual host and wordpress mixed content problem

i get mixed content error when trying to use caddy with apache2, please help me

  1. Caddy version (caddy version):
    v2.1.1 h1:X9k1+ehZPYYrSqBvf/ocUgdLSRIuiNiMo7CvyGUQKeA=

  2. How I run Caddy:
    i m using apache2 with virtualhost at custom port 8001 to host my wordpress site
    this is my configuration:
    cat Caddyfile: {
    reverse_proxy * {
    to 158.xx.xx.xx:8001

my apache virtual host file:
cat /etc/apache2/sites-available/
Listen 8001
NameVirtualHost *:8001
<VirtualHost *:8001>
DocumentRoot /var/www/
ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

System environment:
i m in ubuntu 20.04

Howdy @Hsouna_Zinoubi, welcome to the Caddy community.

I looked at but found no Caddy instance, just a single Apache server on default ports with a self-signed certificate.

Without a site to look at, and with half of the help template missing, there’s not much I can do to help you specifically, I’m afraid. I can point you at some general resources, such as Google’s web developer docs and a neat little tool for diagnosing mixed content.

What is mixed content?

Here are the parts of the template that weren’t answered:

3. The problem I’m having:

What are you trying to do, and what isn’t working? Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you’re seeing. Be as specific as possible.

4. Error messages and/or full log output:

Please DO NOT REDACT any information except credentials.

5. What I already tried:

Show us what effort you’ve put in to solving the problem. Be specific – people are volunteering their time to help you! Low effort posts are not likely to get good answers!

6. Links to relevant resources:

This topic was automatically closed after 30 days. New replies are no longer allowed.