Caddy 2.5 beta 1 released

After 10 months of combined efforts, the first beta for Caddy 2.5 is now available:

This is a huge milestone and we couldn’t have done it without your help, thank you. Please try it out and report any issues before we tag stable!

Caddy relies on sponsors

Did you know that I work on Caddy as my job? And now I support a family. :slight_smile: If your company or its customers use Caddy, sponsorships are not only greatly appreciated, but also crucial to keeping the project going strong. There’s some great benefits available for your team as well!

Thank you to all current sponsors who make this possible, especially ZeroSSL (our executive sponsor). We look forward to serving you!

6 Likes

I am happy to give it a go. Is there an easy way to upgrade, like

caddy upgrade

or do I need to download from github?

1 Like

Right now the caddy upgrade command only upgrades to stable versions (would be a nice feature though) – so you’ll have to download from GitHub for the time being. Or use xcaddy.

I tried this:
https://caddyserver.com/api/download?os=linux&arch=amd64&p=github.com/caddyserver/caddy/v2@v2.5.0-beta.1&p=github.com/caddy-dns/lego-deprecated
as I want it with the plugin as well. This normally works for stable before the download page is updated. I get this error:
{“status_code”:400,“error”:{“message”:“unable to fulfill download request”,“id”:“7538c7fd-f1ad-4f26-8464-7ca8fd1f6a84”}}

1 Like

Ah you’re sneaky :wink: yes that’ll work.

And I dunno why that error happened, that link works for me.

1 Like

I tried this:

curl --output x https://caddyserver.com/api/download?os=linux&arch=amd64&p=github.com/caddyserver/caddy/v2@v2.5.0-beta.1&p=github.com/caddy-dns/lego-deprecated

but when I do

./x version

it still says 2.4.6 . Not sure it is grabbing the right executable.

Coming from you that’s a compliment!

Works for me now too.

Mine is correct:

INFO: Prepare Caddy...
DEBUG: Set custom Caddy binary path
INFO: Found custom Caddy at /share/caddy2/caddy
v2.5.0-beta.1 h1:lF5wWqqDJ6HjETbnBILvTAeKcThsz1+OeWB+d1tWxp4=
INFO: Prepare Caddyfile...
DEBUG: Set custom Caddyfile path
INFO: Caddyfile found at /share/caddy2/Caddyfile
INFO: Run Caddy...
2 Likes

Not sure why that is for you, I ran those commands just now (on my Macbook) and running strings ./x | grep v2.4.6 shows nothing, whereas strings ./x | grep v2.5.0 yields v2.5.0-beta.1. So it is definitely working :man_shrugging:

I have no idea. I just did what you did on my imac and I still get 2.4.6. But, I opened a browser and just downloaded the file and then I get 2.5.0 … so all good. Some reason curl isn’t getting the right file. Crazy. I will deploy it tomorrow on one of my linux servers. thanks everyone!

2 Likes

Thank you for helping to test it out!

I just updated to 2.5 and would have never noticed. Everything’s humming along great <3

3 Likes