Caddy 2.5.2 released

Hi everyone, Caddy v2.5.2 has been released and is now recommended for all users! It contains many bug fixes, new features, and enhancements to existing features!

Thanks to everyone who contributed!

Caddy relies on sponsors

Did you know that Caddy is my day job? And now I support a family of five. :sweat_smile: If your company or its customers use Caddy, sponsorships are crucial to keeping the project maintained and developed. There’s some great benefits available for your team, and we greatly appreciate your support/business! Feel free to get in touch with me if you have any questions or want to customize your sponsorship.

6 Likes

So the download page is still downloading 2.5.1. I normally override this by using this command: https://caddyserver.com/api/download?os=linux&arch=amd64&p=github.com/caddyserver/caddy/v2@v2.5.2&p=github.com/caddy-dns/lego-deprecated
As I want to build it with the dns plugin. But I am getting a return like this
{“status_code”:400,“error”:{“message”:“unable to fulfill download request”,“id”:“2ab09d35-fc28-4d3a-a685-9a04033316a2”}}
What am I doing wrong?
EDIT: just built with xcaddy a PITA. Still like to know why it failed. Also would be great if the download page on the site sjhowed which version it is going to download.

1 Like

Hmm, currently investigating why that fails. Please hold.

1 Like

Ah… dang, I kind of thought this issue was behind us, or taken care of upstream, but I guess not:

caddy imports
        github.com/caddyserver/caddy/v2/modules/standard imports
        github.com/caddyserver/caddy/v2/modules/caddyhttp/standard imports
        github.com/caddyserver/caddy/v2/modules/caddyhttp imports
        github.com/google/cel-go/parser imports
        github.com/antlr/antlr4/runtime/Go/antlr: ambiguous import: found package github.com/antlr/antlr4/runtime/Go/antlr in multiple modules:
        github.com/antlr/antlr4 v0.0.0-20200503195918-621b933c7a7f (/var/lib/caddy/go/pkg/mod/github.com/antlr/antlr4@v0.0.0-20200503195918-621b933c7a7f/runtime/Go/antlr)
        github.com/antlr/antlr4/runtime/Go/antlr v0.0.0-20220418222510-f25a4f6275ed (/var/lib/caddy/go/pkg/mod/github.com/antlr/antlr4/runtime/!go/antlr@v0.0.0-20220418222510-f25a4f6275ed)

It was a whole long thing:

So it turns out, the problem sucks and it’s really an issue with how Go dependency management works.

Here are the solutions we ultimately came up with:

  • All Caddy plugins need to reference v2.5.2+ in their go.mod files
  • Or, xcaddy v0.3.0+ needs to be used

I re-confirmed the first solution works by upgrading lego-deprecated to use Caddy v2.5.2. But that’s only 1 plugin. The build server was running an older version of xcaddy, which I just upgraded. So that should fix things for every plugin on our build server.

@DavidFW1960 Your download should work now. Sorry for the trouble, it was a busy day.

Thanks to @francislavoie and @Mohammed90 and other collaborators who keep track of things so well, this was quite easy to fix.

3 Likes

Thanks Matt… That indeed fixed it

1 Like