Beta v2.7.0-beta.2 warns > send buffer size - during startup

So after compiling the latest beta.2 and current plugins into the mix

GitHub - caddy-dns/cloudflare: Caddy module: dns.providers.cloudflare
GitHub - caddyserver/transform-encoder: Log encoder module for custom log formats
GitHub - WeidiDeng/caddy-cloudflare-ip

I could not stop noticing that this error suddenly shows, is this something we should just ignore and will be fixed or is this something we need to manually change our self, if yes how via CaddyFile?

2023/06/28 09:52:58.329 ←[34mINFO←[0m connection doesn’t allow setting of send buffer size. Not a *net.UDPConn?. See UDP Receive Buffer Size · quic-go/quic-go Wiki · GitHub for details.

Going to the url found in logs says the link has moved and you will have to go here instead.

UDP Buffer Sizes · quic-go/quic-go Wiki · GitHub

I mean, the wiki page literally tells you it’s something you should fix on your own server. There’s instructions there.

1 Like

There’s no instructions for it since its windows, I was just wondering since this did not show up with older caddy release.

I however tried various windows solutions to change the udp buffer size and reboot the server, it had no effect on that message during caddy startup, but it also says doesn’t allow setting of send buffer size Guess I’ll ignore it for now.


1 Like

Oh, you’re on Windows? I have to admit I do not know how to handle this on Windows. That might be something to ask a Windows guru or even Microsoft support. (It’s a paid OS after all, they better support it.)

1 Like

Yeah I did this after some reading

Made registry file.

Saved it as udpbuffer.reg

and ran it, then rebooted.

That is from official documentation and what people write on the net

Windows Registry Editor Version 5.00


I guess it might be fixed but only that the plugin doing a warning about it not being able to detect if it has been changed since its windows, perhaps?

Guess I can try contact the dev of the plugin.

1 Like

Alright I made a ticket at them, he already responded and mentioned its prob a bug in caddy for not supporting it?

1 Like

Yeah, that’s interesting. I saw it and replied but then GitHub went down when I went to submit. Oops?

It’s like 100% totally down. I can’t do anything right now. Is GitHub Down? | Hacker News

But, basically: We do implement the SetReadBuffer method, so I’m not sure why the type assertion is failing.

1 Like

All good, I see you are in a conversation with him now :smiley:

Hey I baked the latest caddy version, and the error is not showing up anymore, so this was good it was brought up to attention right?,

It seems a few people went in on this and you all fixed it rather quickly.

Good job.

1 Like

thats weird, I just built 2.7.0-beta.2 and getting the same warning.

connection doesn't allow setting of send buffer size. Not a *net.UDPConn?. See for details.

I have already set limits on Ubuntu

net.core.wmem_max = 2500000
net.core.rmem_max = 2500000

uname -a
Linux staging 5.15.0-71-generic #78-Ubuntu SMP Tue Apr 18 09:00:29 UTC 2023 x86_64 x86_64 x86_64 GNU/Linux


FROM caddy:2.7.0-beta.2-builder-alpine AS builder

RUN xcaddy build \
    --with \
    --with \
    --with \
    --with \
    --with \
    # --with \
    # --with

FROM caddy:2.7.0-beta.2-alpine

COPY --from=builder /usr/bin/caddy /usr/bin/caddy
RUN apk add --update curl

CMD ["caddy", "run", "--config", "/etc/caddy/Caddyfile", "--environ"]
2023-07-25 21:36:37.809	using provided configuration
2023-07-25 21:36:37.819	Caddyfile input is not formatted; run 'caddy fmt --overwrite' to fix inconsistencies
2023-07-25 21:36:37.823	admin endpoint disabled
2023-07-25 21:36:37.824	server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS
2023-07-25 21:36:37.824	enabling automatic HTTP->HTTPS redirects
2023-07-25 21:36:37.824	server is listening only on the HTTP port, so no automatic HTTPS will be applied to this server
2023-07-25 21:36:37.824	started background certificate maintenance
2023-07-25 21:36:37.826	starting reload ticker
2023-07-25 21:36:37.826	reloading database
2023-07-25 21:36:37.826	reload successful
2023-07-25 21:36:37.833	enabling HTTP/3 listener
2x		2023-07-25 21:36:37.833	server running
2023-07-25 21:36:37.833	enabling automatic TLS certificate management
2023-07-25 21:36:37.835	connection doesn't allow setting of send buffer size. Not a *net.UDPConn?. See for details.
2023-07-25 21:36:37.835	autosaved config (load with --resume flag)
2023-07-25 21:36:37.835	serving initial configuration
2023-07-25 21:36:37.835	cleaning storage unit
2023-07-25 21:36:37.836	finished cleaning storage units
2023-07-25 21:38:14.828	handled request

You need to be running from the latest commits, I believe. The patch only landed on June 30, but Beta 2 was released on June 21.

1 Like

thank you, works :rocket:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.