404 on very basic reverse proxying for SSL Termination (noob)

1. Caddy version (caddy version):

2.1.1

2. How I run Caddy:

caddy reverse-proxy --from https://my2.webconf.me --to http://my.webconf.me

a. System environment:

Ubuntu Server 18.04

b. Command:

caddy reverse-proxy --from https://my2.webconf.me --to http://my.webconf.me

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile or JSON config:

n/a

3. The problem I’m having:

I’m trying to do a very basic reverse proxy to provide SSL termination to a site that currently does not have it (http://my.webconf.me). The new site (my2.webconf.me) has an A record pointing to the caddy public ip, and https seems to be working fine (got the certificate from Let’s Encrypt), but when I hit the URL I only get a 404.

4. Error messages and/or full log output:

5. What I already tried:

Following the docs about using caddy as a Reverse Proxy.

6. Links to relevant resources:

Did you cut and paste your command? Because if so the problem is that you mistyped the “to” address (“f” missing).

Paul

1 Like

Hi, thanks for answering. typed the command, but in the server it’s fine. Just double checked it

caddy reverse-proxy --from https://my2.webconf.me:443 --to http://my.webconf.me:80

So this is solved?

Nop, it was just a typo on the question (which I have already edited). The problem still persists.

Thanks

There’s not really enough information here. What’s in your logs? What do you see if you use curl -v to make the request?

I’m sorry, I just didn’t have enough time to go through with the investigation. Removed Caddy and installed Nginx, and was able to setup the reverse proxy fairly easily.
I’m sorry caddy didn’t work for me this time.

Thanks for the help!