Wordpress Setup for newbie

1. Caddy version (caddy version):

v2.3.0 h1:fnrqJLa3G5vfxcxmOH/+kJOcunPLhSBnjgIvjXV/QTA=

2. How I run Caddy:


a. System environment:

Ubuntu 20.04.1 LTS (GNU/Linux 5.4.0-51-generic x86_64)

b. Command:

"ssh root@ _servers_ip"

d. My complete Caddyfile or JSON config:

wordpress.dorokhov-portfolio.pl {
        root * /home/www/dorokhov-portfolio.pl/wordpress
        php_fastcgi / php
dorokhov-portfolio.pl {
    root * /home/www/dorokhov-portfolio.pl/dorokhov-portfolio

ser-deczny.pl {
root * /home/www/sertest

kinoclub.pl {
root * /home/www/kinoclub

3. The problem I’m having:

Hello! I am totaly new to caddy and servers in general. i am trying to intall wordpress. And it just doesnt work.

4. Error messages and/or full log output:

WordPress requires that your web server is running PHP. Your server does not have PHP installed, or PHP is turned off.

5. What I already tried:

What I already tried: I have installed php, mySql, make database and user and set up config.php file in wordpress folder. I totaly dont know what should i put in ‘php_fastcgi’ i think problem may be there.

You have a mix of Caddy v1 and Caddy v2 syntax here. It should look like php_fastcgi, i.e. there’s no php at the end, and no /.

Anyways, essentially, you’re looking to install php-fpm. You can use Google to find plenty of guides on this topic, it’s out of scope of Caddy. But depending on how php-fpm is installed or run, you’d configure Caddy to connect to php-fpm either via TCP, usually on port 9000 (i.e., or via a unix socket, which is a “file” that acts like a pipe by using system calls for communicating instead of the network stack (i.e. unix//run/php/php-8.0-fpm.sock, where the version number can depend on the version of PHP you installed; unix/ is a prefix to tell Caddy that what follows is a path to a file that acts as a unix socket).

1 Like

Thank you so mach!!! As i said im total newbie and actualy installed php for apache server lol. i used this instraction and all worked fine:

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.