Unrecognized directive: cache

1. Caddy version (caddy version):

v2.3.0 h1:fnrqJLa3G5vfxcxmOH/+kJOcunPLhSBnjgIvjXV/QTA=

2. How I run Caddy:

a. System environment:

Ubuntu 20, using systemd

b. Command:

/usr/bin/caddy run -config=/etc/caddy/Caddyfile

c. Service/unit/compose file:

not relevant. Getting same results in cli as in systemd

d. My complete Caddyfile or JSON config:

example.com {
  reverse_proxy / localhost:8002 {
  log {
    output stdout
    level  debug

  cache {
    match_path /mypath
    default_max_age 10m
    path /tmp/caddy-cache

3. The problem I’m having:

I get unrecognized directive: cache. Am trying to cache like I did in Caddy1.

4. Error messages and/or full log output:

unrecognized directive: cache

5. What I already tried:

Tried it on caddy 1 but since that is no longer supported I am moving to caddy 2. Also tried searching through the code and docs for caching layer but no luck.

6. Links to relevant resources:

Just answered here:


This topic was automatically closed after 30 days. New replies are no longer allowed.