Snippet no longer pulling

1. The problem I’m having:

I’ve been running this config for a couple years now and for some reason certificates are not renewing. I’ve rolled the dns key to make sure that wasn’t the issue. Not sure what is going on. Any advice on what to check next?

2. Error messages and/or full log output:

caddy[3806126]: {"level":"error","ts":1680888660.7025175,"logger":"http.handlers.reverse_proxy","msg":"aborting wit

3. Caddy version:


4. How I installed and ran Caddy:

xcaddy custom build

a. System environment:


b. Command:

c. Service/unit/compose file:

Description=Caddy Reverse Proxy

ExecStart=/usr/bin/caddy run --environ --config /etc/caddy/Caddyfile --log /etc/caddy/caddy.log
ExecReload=/usr/bin/caddy reload --config /etc/caddy/Caddyfile


d. My complete Caddy config:

(snip) {
    header {
        # Enable HSTS
        Strict-Transport-Security "max-age=31536000; includeSubDomains; preload"

        # Referrer Policy retains much of the referrers usefulness while mitigating the risk of leaking data
        Referrer-Policy "strict-origin-when-cross-origin"

        # Disable FLoC tracking
        Permissions-Policy interest-cohort=()

        # Gets the clients IP address
        X-Real-IP {http.request.remote}

        # Forwards clients IP
        X-Forwarded-For {remote_host}

        # Stops pages from loading when they detect reflected cross-site scripting attacks
        X-XSS-Protection "1; mode=block"

        # Disable clients from sniffing the media type
        X-Content-Type-Options "nosniff"

        # Clickjacking protection
        X-Frame-Options "DENY"            
    tls {
        issuer acme {
                email "My Email Address"
                dns cloudflare "My Cloudflare key"
    encode zstd gzip
} {
    import snip    

5. Links to relevant resources:

I added the disable_http_challenge to make sure it wasn’t using this.
I’ve tried switching to zerossl and this fails to pull certs as well.

That log message is incomplete.

Please show your complete logs, it’s impossible to know what’s going on without more detail.

Instead of rolling key I just created an outright new api key and that worked. Not sure why this happened but that fixed it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.