Security certificate unknown

1. Caddy version (caddy version):


2. How I run Caddy:

not using Domain name, just IP of server in caddyfile

a. System environment:

Windows Server 2016

b. Command:


c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

51.X.X.192 {
root * /www/

3. The problem I’m having:

Trying to access a video file in VLC on the machine via https:// but getting this error;
You attempted to reach, x.x.x.x However the, security certificate presented by the server is unknown and could not be authenticated by any Trusted Certificate authority.

4. Error messages and/or full log output:

5. What I already tried:

6. Links to relevant resources:

If you use just an IP address, it’ll trigger Caddy’s Local HTTPS functionality:

You’ll need to make sure your client trusts Caddy’s root CA cert.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.