Reload failed for Caddy

1. Caddy version (caddy version): 2.4.4

2. How I run Caddy:

Caddy run

a. System environment:

Ubuntu 20.04.3

b. Command:

sudo systemctl reload caddy

c. Service/unit/compose file:

d. My complete Caddyfile or JSON config:


(static) {
@static {
path *.ico *.css *.js *.gif *.jpg *.jpeg *.png *.svg *.woff *.json
header @static Cache-Control max-age=5184000.

(segurity) {
header {
# enable HSTS
Strict-Transport-Security max-age=31536000;
# disable clients from sniffing the media type
X-Content-Type-Options nosniff
# keet referrer data off HTTP connections
Referrer-Policy no-referrer-when-downgrade

3. The problem I’m having:

Hello, I am trying to run “sudo systemctl reload caddy” but I get the following error. My hrothgar.conf file is {
encode zstd gzip
import static
import security

    root * /var/www/hrothgar


log {

output file /var/logs/…

format single_field common_log



4. Error messages and/or full log output:

5. What I already tried:

6. Links to relevant resources:

Please fix your post’s formatting, it’s very difficult to read your Caddyfile. Make sure to use code fence delimiters ``` on their own lines before and after your config and logs.

To read your logs, please use the command outlined on this page in the docs. As you can see in your screenshot, the error message is cut off because that command truncates long lines.

This topic was automatically closed after 30 days. New replies are no longer allowed.