Reaver Proxy with Overseerr Help

1. Output of caddy version: 2.6.2

2. How I run Caddy:

Docker container using this command to run the container: docker run -d --name caddy -p 80:80 my-caddy. I’ve built the image from the caddy image using my caddyfile. All it has in the caddy file is: {

a. System environment:

windows 11. Docker desktop latest version

b. Command:

Paste command here.

c. Service/unit/compose file:

Dockerfile contains this: FROM caddy
COPY caddyfile /etc/caddy/Caddyfile
I run this to build the image:  docker build -t my-caddy . Then I run this to run the container: docker run -d --name caddy -p 80:80 my-caddy

d. My complete Caddy config: i haven’t changed anything in the config file so it would be all the defaults. I can still post it though if needed.

3. The problem I’m having:

I’m trying to reverse proxy Overseerr to So if I browse it brings up the app. I’ve added my external ip address of my computer to the dns record of my domain. I can go to but it pulls up my modem login screen. Not the Overseerr app. I’m not sure what step I’m missing in all of this.

4. Error messages and/or full log output:

Not even sure what logs I would really need at this point. I think it’s more of a configuration issue.

5. What I already tried:

I’ve seen other post on the forum with sonarr and radarr and have tried different combinations of a caddy file and docker commands like this docker run -d --name caddy -p 80:80 --link overseerr:localhost my-caddy. I’ve also tried putting the container name which is Overseerr in the caddyfile instead of the up address but that didn’t help either.

6. Links to relevant resources:

You’re only publishing port 80, the HTTP port; Caddy will attempt to serve HTTPS when you give it a domain as the site address, so that’s not enough. You need to also publish port 443 for HTTPS.

Your modem is probably intercepting traffic on port 443. You’ll need to turn that off, and port forward 443 to your server as well.

Hi @francislavoie
Do you know what that setting might be called? I have a ZyXEL modem. I’ve done some googling but not finding anything that is standing out besides just turning off the firewall which I wouldn’t think that I’d want to do that.

Look for “Port Forwarding” under Firewall section , or under “Virtual Server” for some routers.
If you can, post a screenshot of your modem page


Hi @gyfer
Here is what I have under the firewall section.

Then I found port forwarding under my NAT. See here

Appreciate the help!

The last pic is where you want.
Add TWO service, for BOTH HTTP and HTTPS, Click “Add New Rule”

Service Name: *HTTP and HTTPS, or up to you
Originating IP : *leave blank
Server IP Address : *this will be your Caddy IP
Start port , End Port : T. Start Port, T. End Port : 80 (for HTTP), 443 (for HTTPS)
Protocol : TCP+UDP ( or just TCP if option not available)


1 Like

Sorry @gyfer for the late reply. Thanks for yours and @francislavoie assistance. I got it working.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.