PHP not working

1. Caddy version (v2.3.0):

2. How I run Caddy:

a. System environment:

linux ubuntu 20.04

b. Command:

caddy run --config caddyDir/Caddyfile

c. Service/unit/compose file:

I dont know..

d. My complete Caddyfile or JSON config: {
} {
} {

3. The problem I’m having:

My site can’t get the PHP file that is in static, but when I go to the PHP file itself it downloads

4. Error messages and/or full log output:


5. What I already tried:

I tried moving the PHP file, it can’t seem to find it

Well, you’re just using reverse_proxy, which asks an upstream server to handle the request. You need to have something that’s running PHP.

Either install php-fpm and configure Caddy with the php_fastcgi directive, or set up the server you’re proxying to to execute PHP scripts.

You didn’t provide enough information to show what you’re actually proxying to, nor did you show your logs, so I can’t do any more to help without more clarifying information.

That’s all the info I need, thanks a lot. :smiley:

This topic was automatically closed after 30 days. New replies are no longer allowed.