Paths with uppercase letters aren't working

1. Caddy version (caddy version):

v2.2.1 h1:Q62GWHMtztnvyRU+KPOpw6fNfeCD3SkwH7SfT1Tgt2c=

2. How I run Caddy:

caddy run

a. System environment:

ubuntu 18.04

b. Command:

c. Service/unit/compose file:

d. My complete Caddyfile or JSON config: {
  root * /srv/html

3. The problem I’m having:

My customer sends our their URLs on print materials with capitals. I need URL paths to be assumed to be all lowercase. Would appreciate any help the community can offer with how to configure this using Caddyfile.

I’m having trouble finding an answer because there was a v1 bug related to capitalization and anything I find seems to be related to that.

4. Error messages and/or full log output:

5. What I already tried:

6. Links to relevant resources:

When I try

redir /Research /research

for example… I get a redirect loop

So I have no idea how to address the issue as of now

Caddy’s path matcher is case-insensitive:

But you can use a regexp matcher for a case-sensitive match: Request matchers (Caddyfile) — Caddy Documentation

So I should not be experiencing this behavior? {
  root * /srv/html/



Well, can it be found? What does ls -la /srv/html/Research output?

This topic was automatically closed after 30 days. New replies are no longer allowed.