Only getting "Fake LE Intermediate X1" intermediate certificate

According the log-files, it seems that the Lets Encrypt functionality is… working. But I am only getting “Fake LE Intermediate X1” as the intermediate cert. As such, I am still getting the “Certificate Error: There are issues with the site’s certificate chain (net::ERR_CERT_AUTHORITY_INVALID).”

In the log-files, I see:
==> syslog <== │
Jul 13 18:22:17 my-site-here systemd[1]: Starting Caddy webserver using uWSGI… │
Jul 13 18:22:17 my-site-here systemd[1]: Started Caddy webserver using uWSGI. │
Jul 13 18:22:17 my-site-here caddy.arm6[9416]: Activating privacy features… done. │
Jul 13 18:22:17 my-site-here caddy.arm6[9416]: │
Jul 13 18:22:17 my-site-here caddy.arm6[9416]:

I’m using Caddy on an Raspberry Pi B+, using the ‘fastcgi’ directive which is tied to a uWSGI Python application. Version: Caddy 0.8 beta 4

There are *.key and *.json files in both the URL and the ‘user’ folders in .caddy/letsencrypt folder. There is also a .crt file in the URL folder.

I thought I had read that sometimes it can take up to 15 minutes for the ‘final’ certificates to make it to my server. After 3 hours, I still get the bad-intermediate-cert error.

So: is there anything I should be doing differently to stop getting the Certificate Error?

Hey dmalouf, thanks for your question. Welcome!

That version of Caddy is over 6 months old. :thinking: I don’t even remember its Let’s Encrypt configuration.

Anyway, if that’s your only site on your Raspberry Pi, delete the ~/.caddy/letsencrypt folder, download the latest version of Caddy, and try again.

1 Like

Just to follow-up, I got the latest Caddy from Github (go get, cross-compiled for ARM6, and boom - it worked perfect!

Thank you for your continued work on this product. It’s awesome. period. AND it’s great to have such a ‘thin’ server to run on my Raspberry Pi - a not-new one that has NO problem with Caddy. I’m very grateful for this software!


Just to mention it here, you can also download an arm6 binary from the website

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.