Nslookup checks out, but I'm not hitting my applications using a FQDN

1. Caddy version (caddy version):

Whatever is the latest

2. How I run Caddy:

Though Docker via unRAID

a. System environment:

unRAID Docker

b. Command:


Paste command here.

c. Service/unit/compose file:


Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:



3. The problem I’m having:

Not resolving

4. Error messages and/or full log output:

{"level":"info","ts":1646698287.085654,"msg":"using provided configuration","config_file":"/etc/caddy/Caddyfile","config_adapter":"caddyfile"}
{"level":"warn","ts":1646698287.0865178,"msg":"input is not formatted with 'caddy fmt'","adapter":"caddyfile","file":"/etc/caddy/Caddyfile","line":4}
{"level":"info","ts":1646698287.087166,"logger":"admin","msg":"admin endpoint started","address":"tcp/localhost:2019","enforce_origin":false,"origins":["localhost:2019","[::1]:2019",""]}
{"level":"info","ts":1646698287.0872614,"logger":"http","msg":"server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS","server_name":"srv0","https_port":443}
{"level":"info","ts":1646698287.0872767,"logger":"http","msg":"enabling automatic HTTP->HTTPS redirects","server_name":"srv0"}
{"level":"info","ts":1646698287.0874045,"logger":"tls.cache.maintenance","msg":"started background certificate maintenance","cache":"0xc0003c6930"}
{"level":"info","ts":1646698287.0875642,"logger":"http","msg":"enabling automatic TLS certificate management","domains":["plex.digitalwashu.net"]}
{"level":"info","ts":1646698287.0875852,"logger":"tls","msg":"cleaning storage unit","description":"FileStorage:/data/caddy"}
{"level":"info","ts":1646698287.0996137,"msg":"autosaved config (load with --resume flag)","file":"/config/caddy/autosave.json"}
{"level":"info","ts":1646698287.0996256,"msg":"serving initial configuration"}
{"level":"info","ts":1646698287.1982331,"logger":"tls","msg":"finished cleaning storage units"}

5. What I already tried:

6. Links to relevant resources:

This is likely not Caddy-specific. I can’t seem to get reverse proxy to work with ANY rev proxy tool. MY firewall is pfSense, and in it, I have 80 and 443 open. I have NAT set to forward 80–>1880 and 443–>18443.

I’m completely baffled as to why this isn’t working. I will say however Caddy is WILDLY more simple than traefik/nginx/haproxy. Holy smoke.

1 Like

I don’t understand what you’re saying is the problem. I’m not seeing any errors in those logs, nor an example of a curl -v request to show what’s not working. What have you tried? Please be more specific.

What version, exactly? We can’t trust “latest” to actually be the latest. Please run caddy version in the container to find the exact version.

Thank you so much for your reply! 2.4.6 h1

Are you saying that plex.digitalwashu.net is resolving to a plex installation?

I’m saying I have no idea what you’re trying to describe as a problem. What’s not working? What did you try? Make a request with curl -v to show the problem, etc.


This topic was automatically closed after 30 days. New replies are no longer allowed.