New Reverse proxy entry in a caddyfile getting: ERR_SSL_PROTOCOL_ERROR

1. Caddy version (Lateset Docker image):

2. How I run Caddy:

In a Docker as a reverse proxy to other docker images.

a. System environment:

Docker, running on a Debian server

b. Command:

Docker file

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

3. The problem I’m having:

When I curl from the same machine I get the correct HTML response, but when I’m browsing to the A record that redirects to this docker I get the error in the title.
Other dockers work fine.

4. Error messages and/or full log output:

5. What I already tried:

restarting caddy, and changing the port and A record, nothing changed.

6. Links to relevant resources:

If you’re running in Docker, how are you running it?

You need to make sure ports 80 and 443 are forwarded, and can reach Caddy.

What’s in Caddy’s logs?

What version exactly? “Latest” is not specific, and is dependent on when you last pulled the image.

The other entries on the caddyfile work ok, so the ports are open to caddy, which is why it is so weird to me that it’s not working.
The image for caddy was from 8 weeks ago, and I tried to pull a new one today, it said it was up-to-date.

As for the log, remind me again, what’s the location on that? It’s been a while since I had to mess around with caddy.

Never mind, I edited the wrong file, I edited the file in /etc/caddy/Caddyfile instead of /etc/Caddyfile.