Need help installing v1 with a plugin

1. Caddy version (caddy version): v1

2. How I run Caddy:

on Raspbian RPi4

a. System environment:

Standard Raspberry Pi Enviornment

b. Command:


3. The problem I’m having:

I need to use the http.forwardproxy plugin, which is not supported by Caddy v2. I am in urgent need of a way to install v1 with that plugin on my server.

5. What I already tried:

I’ve tried building from source, but have absolutely no idea what I’m doing it

6. Links to relevant resources:

I’ve tried accessing a link that was created by the old url but this hasn’t worked form me and gave me a 404

The build instructions are found on github under the v1 branch: GitHub - caddyserver/caddy at v1

How do I specify the plugin?

It’s explained right in those instructions.

The instructions are outdated and not working.

What’s not working? Please be specific.

its says "./main.go:5:2: imported and not used: “” and then doesnt build anything

The instructions are right. What’s your main.go file?

i made a folder with it in my home directory

… and what’s in it?

the main.go file

package main

import (

func main() {
	// optional: disable telemetry
	// caddymain.EnableTelemetry = false

Ah, you missed this part in the instructions:

	// plug in plugins here, for example:
	// _ "import/path/here"

Note the _ omitted in your file.

okay that fixed that problem, but now when i try to run caddy it gives me
panic: qtls.ConnectionState not compatible with tls.ConnectionState

Unfortunately our HTTP/3 dependency does not support Go 1.15; you’ll have to downgrade to Go 1.14 or remove the code that does HTTP/3.

okay got most everything working but now im getting:

Sep 21 21:13:00 carbon caddy[2076]: 2020/09/21 21:13:00 [ERROR][] failed to obtain certificate: acme: error: 429 :: POST :: :
Sep 21 21:13:01 carbon caddy[2076]: 2020/09/21 21:13:01 [INFO] [] acme: Obtaining bundled SAN certificate

any ideas?

@matt I really need a solution

Can you please share more details? E.g. your Caddyfile, system setup, more log lines, etc.

I think your log line was truncated, so it’s hiding the real error message. Please make sure that whatever terminal program you’re using doesn’t cut off the ends of the lines. less usually does the job pretty well.

This topic was automatically closed after 30 days. New replies are no longer allowed.