Multiple DNS Providers

Hi All,

Trying to install Caddy on ubuntu 16.04 using the curl script from the download page. I am encountering an issue where if i select more than one DNS provider plugin the download fails. If i select one however it works. Is this expected behaviour?

Does not work:
curl | bash -s personal hook.service,http.ipfilter,http.jwt,http.login,tls.dns.cloudflare,

Does work:
curl | bash -s personal hook.service,http.ipfilter,http.jwt,http.login,tls.dns.cloudflare

Does work:
curl | bash -s personal hook.service,http.ipfilter,http.jwt,http.login,

Any thoughts?

Hmm, the logs show this error:

fork/exec /usr/bin/git: no such file or directory

When you do a build, it pulls down the latest and checks out the last released version, which is why git is called. It’s strange that it says git does not exist, because it definitely does.

Is it only that combination that fails, or is it intermittent?

Thats the same error that i get when using the direct url.

I have just tried this,,http.ipfilter,http.jwt,http.login,tls.dns.digitalocean,tls.dns.linode&license=personal&telemetry=off

So linode and DigitalOcean, and they both work ok together, to be honest, i was looking to get all of the plugins and it would take me a while to work out all combinations that work :frowning:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.