Invalid signature on JWS request - HTTP 400 ZeroSSL

1. Caddy version (caddy version):


2. How I run Caddy:

caddy start

a. System environment:

Windows Server AMD64

b. Command:

caddy start

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

3. The problem I’m having:

Certificate renewal with ZeroSSL does not work.

4. Error messages and/or full log output:

2022/01/06 04:36:38.950 ERROR tls.renew could not get certificate from issuer {“issuer”: “”, “error”: “HTTP 400 urn:ietf:params:acme:error:malformed - Invalid signature on JWS request”}
2022/01/06 04:36:38.950 ERROR tls.renew will retry {“error”: "Renew: creating new order: attempt 1: HTTP 400 urn:ietf:params:acme:error:m

5. What I already tried:

Upgraded version of Caddy from v2.3.0 to v2.4.6

6. Links to relevant resources:

Please properly fill out the help topic template. What’s your config? It matters.

You can try wiping out Caddy’s storage and restarting Caddy to get a fresh set of certificates.

This did the trick, thanks.

This topic was automatically closed after 30 days. New replies are no longer allowed.