How to get caddy working for Odoo 10 on Windows 2012 Server?


I have successfully installed Odoo 10 on a Windows 2012 R2 platform.

Set up was successful and the installation is accessible locally and via internet ( on http.

I am now trying to get this to work on SSL, but I have no idea how to start here.

What I tried is to run caddy. I run into two problems:

  1. I read that I have to point caddy to the root folder where the index file is. However, I can’t find the right odoo folder that has an index folder. I still get the correct 404 page from caddy though.

  2. the provider for my domain1 does not support lets encrypt (godaddy); however, I have separately purchased a commodo certificate for, but i am not sure how to use that.

I am not sure whether caddy is actually the right solution? I have not much experience in setting this kind of thing up. What other options are there to easily get this platform onto ssl? I would want to stay away from VPN as a last resort…

Thanks so much for any insight!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.