How to check the logs of caddy-api and also unable to access caddy response with the load balancer?

1. Caddy version (caddy version):v2.4.5

2. How I run Caddy:

a. System environment:

Ubuntu, 20.4, No

b. Command:

Sudo Systemctl enable caddy-api

c. Service/unit/compose file:

Paste full file contents here.
Make sure backticks stay on their own lines,
and the post looks nice in the preview pane.

d. My complete Caddyfile or JSON config:

Paste config here, replacing this text.
Use `caddy fmt` to make it readable.
DO NOT REDACT anything except credentials.
Make sure the backticks stay on their own lines.

3. The problem I’m having:

i am unable get logs of caddy.

4. Error messages and/or full log output:

*curl: (35) error:1408F10B:SSL routines:ssl3_get_record:wrong version number

5. What I already tried:


curl localhost:2019/config/logging -X POST -H “Content-Type: application/json” -d ‘{“logs”: {“access”: {“level”: “debug”}}}’

6. Links to relevant resources:caddy documentation

Please fill out the template properly. We can’t help without sufficient and proper details.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.